Функции это специальные текстовые команды, которые реализуют сложные математические операции.
Каждая функция соответствует какой-либо формуле. Например функция СРЗНАЧ сокращает формулу: =(А1+А2+А3+А4+А5+А6+А7)/7 = СРЗНАЧ (А1:А7).

Ввод функций

Функция состоит:

  • знак равенства (=),
  • имя функции – аббревиатура, указывающая значение функции,
  • набор скобок, внутри которых помещают аргументы,
  • аргументы – значения, применяемые в расчетах.

Аргументами могут быть:

  • отдельное значение,
  • отдельная ссылка,
  • серия ссылок на значения или ячейки,
  • диапазон ячеек.

Простейшая функция аргументов не содержит. Например, =СЕГОДНЯ() возвращает текущую дату.
Если в функции используется несколько аргументов, каждый из них отделяется точкой с запятой.

Форматы функций

Большинство функций используют в качестве аргументов числа, но могут принимать и аргументы других типов.
Числовой. Любое целое или дробное число.
Время и дата. Любой допустимый формат времени и даты.
Текст. Текст, содержащий любые символы, заключенные в кавычки.
Логический тип. ИСТИНА/ЛОЖЬ, ДА/НЕТ, 1/0 и вычисляемые логические значения: 1+2=3
Ссылки на ячейки. Большинство аргументов представляют собой ссылки на результаты других ячеек (или групп ячеек) вместо использования явных значений.
Функции. В качестве аргумента можно использовать функцию, если она возвращает тип данных, который необходим для вычисления функции более высокого уровня.

Мастер функций

Для облегчения работы с функциями в Excel существуют два средства: диалоговое окно Мастер функций и инструментальное средство Палитра формул.
Мастер функций можно открыть нажав на кнопку Вставить функцию возле строки формул

Вставить функцию

или через Ленту на вкладке формулы

Вставить мастер функций

В диалоговом окне Мастер функций нужно выбрать категорию. Каждая категория содержит функции, которые решают определенные задачи. По каждой функции можно посмотреть краткое описание или вызвать интернет справку.
После того как вы выберете функцию и нажмете ОК появится Палитра формул, которая предоставляет наиболее простой способ построения функций.

Вложенные функции

В качестве аргументов могут быть использованы формулы или другие функции. Например: =ЕСЛИ(ЕНД(ВПР(B5;справочник!$A$3:$E$199;2;ЛОЖЬ));””;ВПР(B5;справочник!$A$3:$E$199;2;ЛОЖЬ)). Можно использовать до семи уровней вложенности функций. Если этот предел превысить,Excel выдаст ошибку.