Для отображения в ячейке текущей даты используют функцию СЕГОДНЯ, для текущей даты и времени ТДАТА.

Функция СЕГОДНЯ


Синтаксис
СЕГОДНЯ()
У функции СЕГОДНЯ нет аргументов.
Может использоваться как самостоятельно, так и с другими функциями и формулами. Например, можно вывести не только текущую дату, но и текущий день, месяц или год.

Функция СЕГОДНЯ

При использовании функции СЕГОДНЯ в других формулах можно вычислить количество дней до дня рождения сотрудника.
Для начала введем дату, которая будет отображать день рождения сотрудника в текущем году. Для этого вызовем функцию дата и в поле Год введем ГОД(СЕГОДНЯ()) для отображения текущего года, а в поле Месяц и День будут ссылаться на дату рождения.

Сколько дней до дня рождения 1

Затем отнимем сегодняшнее число.

Сколько дней до дня рождения 2

Все даты в Excel хранятся в числовом формате, отсчет начинается с 01.01.1900 года (это будет число 1), поэтому вместо разницы в днях отображается дата, соответствующая этому числу.
Для отображения количества дней поменяем формат ячейки на Общий.

Подробнее Как Excel обрабатывает дату и время

Сколько дней до дня рождения 3

Если день рождения у сотрудника уже было, результат примет отрицательное значение.

Сколько дней до дня рождения 4

Для того, чтобы в таких случаях отсчет шел до следующего года добавим функцию ЕСЛИ.
Для этого в строке формул после знака = нужно дописать ЕСЛИ(
Встать курсором на функцию ЕСЛИ
Нажать на кнопку Вставить функцию

Сколько дней до дня рождения 5

В появившемся окне наша формула отобразится в поле Лог_выражение. Нужно скопировать ее в поля Значение_если_истина и Значение_если_ложь.

Затем внесем изменения в нашу формулу:

Лог_выражение: в конце допишем <0
Значение_если_истина: после (ГОД(СЕГОДНЯ()) допишем +1
Значение_если_ложь: оставим без изменений

Сколько дней до дня рождения 6


То есть если результат формулы будет меньше нуля Excel рассчитает количество дней до следующего года.

Можно ввести формулу вручную:
=ЕСЛИ(ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(B2);ДЕНЬ(B2))-СЕГОДНЯ()<0;ДАТА(ГОД(СЕГОДНЯ())+1;МЕСЯЦ(B2);ДЕНЬ(B2))-СЕГОДНЯ();ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(B2);ДЕНЬ(B2))-СЕГОДНЯ())

Протянем формулу на всех сотрудников.

Сколько дней до дня рождения 7

Функция ТДАТА

Аналогичной функцией СЕГОДНЯ будет функция ТДАТА, только в ячейке будет отображаться дата и время.
Синтаксис
ТДАТА()

Отображение в ячейке текущей даты и времени